New game freezes with original PS & FFVII

Palli

New member
Joined
Jun 16, 2019
Messages
3
Gil
11
Gold Points
0
Community Tokens
0
Morning!

Past week I bought the PS1 and FFVII because I was feeling nostalgic and wanted to play the game again. Now whenever I press new game the PS makes a weird squeaking sound, the disc stops spinning and the screen goes black.
The playstation is brand new and works perfectly. The game is in a good state, no scratches or anything on the disc.

Anyone has an idea of why this is happening ?

EDIT: I do not know if it matters but the Playstation does not (yet) have a memorystick. I thought maybe the game needs one in order to be played but I can't remember that being the case.

Thanks in advance.
 

Vivi-Gamer

Well-known member
Joined
May 5, 2007
Messages
412
Gil
1,566
Gold Points
7
Community Tokens
3
Have you got other games with FMV clips working? Like the intros to Tekken etc.? I've had them jitter and freeze durning play, but never simply not load.

- Try getting it to the point where it freezes and switch to Disc 2, I know it may sound weird but when mine was freesing during the cutscenes I did that before and it skipped them. That may work, but I have a feeling as it is the start it may just ask you o insert Disc 1 again...
 

Palli

New member
Joined
Jun 16, 2019
Messages
3
Gil
11
Gold Points
0
Community Tokens
0
I'll give it a try. Unfortunaly I have no other game to test wether or not the FMV clips are loading properly.
Can we determine that this is a disc problem or is it a PS problem ?

EDIT: Switching disk sweems to work but it just booted normally as well. No idea how to analyze the problem further if it works without reason now...
 
Last edited:

Mitsuki

Staff member
Administrator
Veteran
Joined
Dec 14, 2006
Messages
11,484
Location
California
Gil
5,374
Gold Points
104
Community Tokens
99
FFXIV
Mitsuki Calei
FFXIV Server
Lamia
Free Company
Gaia
I remember doing this for FFVIII. My game froze during that dragon fight with Laguna and company. It kept freezing there. I switched to Disc 4 (or at least I think it was Disc 4...) and the game loaded fine. This was years ago though, I was only 13 years old, so it could be a disc problem?

But hey, glad it works now though! Enjoy the game. =] Thanks @Vivi-Gamer for helping out here!
 
Top